2016年8月28日 (日)

液晶割れ

久しぶりの更新。

開発機を兼ねている僕のケータイ(auSHL25/SHARP)は、ときどき子供のおもちゃになるときがあるんだけど、今日はいつもよりぞんざいに扱われたらしく、初の液晶割れを経験した。

保険に入っていたこともあり、とりあえず近所のauショップに行って代替機の借用と交換機種の取り寄せ手続きをしてきたんだけど、自力でデータ移行をやるのは久しぶり、しかも片方は液晶割れでまったく操作できないというおまけ付き。

「そういえば以前、姉が液晶割れを経験して、USBホストケーブルでマウスをつないで急場をしのいだとか言ってたっけ」ということで、その時の状況を聞いてみると「USBホストケーブル+マウスで1500円くらいだった。そんなに高いものじゃない」とのこと。

さっき調べたら、USBホストケーブル自体は100均でも売っているらしいので、ダメ元で買ってみるか....。

| | コメント (0) | トラックバック (0)

2007年12月10日 (月)

Xacti CA6を買ってみた

 たまたま別の用事で某大型家電量販店に行ったとき、ふらりと立ち寄ったデジカメコーナーのワゴンセール品に、サンヨーのXacti DMX-CA6が混ざっていたのに目が留まった。18,800円なり。なんでも生活防水機能つきで、多少の水しぶき程度では壊れないとか。

 デジカメはすでにキヤノンのPowerShot A540を持ってたけど、でかい防水ハウジングをつけて雪山へ行くのもなんだか、ってことと、MPEG-4ムービーカムと考えればまぁ、妥当なところじゃない? なんて思って、1セットだけ残ったこいつを購入。記録メディアはSDなんだけどセットに入っていないため、一緒にLexarの4GB SDHCカードも購入。結局なんだかんだで33,634円支払った。

 早速バッテリーを充電して、アパートの中でテスト撮影開始。やっぱりメインはムービー撮影かね。ということで動画撮影をちょいとしてみる。側面の液晶モニタを起こすだけで、待機状態からすぐに復帰するところはさすが。やっぱり電源を入れてもレンズがにゅ~っと出てくるまでユーザーを待たせるようなことは、こいつの設計思想に合わない、ってことなんだろう。

 ムービーのエンコード方式はISO MPEG-4のみなんだけど、撮影時のビットレートが比較的高いのかH.264 AV/Cでなくても、十分きれいなムービーが撮影できることに驚いた。ただ、液晶モニタの裏側(撮影時はカメラ方向)についているステレオマイクの集音性能が、期待していたよりも低かったのはご愛嬌か。

 撮影サイズは640x480、320x240、176x144から選択できるが、320x240にすれば、まったく手を加えることなくPSPでも再生できてしまった。こいつは面白すぎる!

 って、俺は何をやろうとしてるんだ(笑)?

| | コメント (0) | トラックバック (0)

2006年11月30日 (木)

EZナビウォーク

 久々の投稿。いや~、最近仕事が立て込んでたもので。ほんと殺人的っすよ。
 と、そんなことはさておき。
 最近はたいていのケータイにGPSレシーバーが入っていて、カーナビの代わりに使うことができるようになっているのは周知の事実で、auのケータイではEZナビウォークなんて名前のアプリがプリインストールされてる。
 仕事柄よく知らない町に出ることがある関係上、こういったものが使えるととても助かるんだけど、どういうわけか、アプリを起動しても衛星をつかまない。この現象に気づいたのは結構前だったんだけど、そのときは知らない土地ではなかったってこともあって、さして重要視していなかった。いや、GPSの仕組みくらい知ってますよ、ぼくは。ちゃんと青空の見えるところで起動してるんですがね。
 そんなわけだから、知らない土地での移動はタクシーで、ってことになっちゃってたんだけど、昨日ふと「そういえば、デフォルトと違うところってmicroSD挿してたことだな。」なんてことを思いついた。
 「まさかなぁ~」なんて半信半疑だったんだけど、W42CAは電池パックを脱着するのがちょいと面倒なんだけど、物は試し、電池パックの奥にあるスロットからmicroSDカード(東芝製、512MB)を引き抜いて起動してみた。
 するとどうだろう、EZナビウォークのアプリがちゃんと衛星をつかんで、自分の位置を表示しているではないですか! つーか、それが当たり前なんだけど。
 と、そこで気になるのは「この現象には再現性があるのか」、ってところ。適当にナビを開始して一通り動作を確認した後、またmicroSDを挿してEZナビウォークを起動。やっぱり衛星をつかまない。そしてmicroSDを抜いてEZナビウォークを起動したら、ちゃんと衛星をつかむ。少なくともW42CAに関しては、再現性があることが確認できた。
 ここでちょっと考えてみる。マスストレージモードでは動くのにau Music Portは使えない、なんて以前書いたけど、そのときもmicroSDを挿した状態でUSB接続していたっけ。それを考えると、モデム部やGPSレシーバ部とmicroSDスロットが同じ部分にぶら下がっていて、microSDを挿すとマスストレージモードが優先されるような構造になっているのでは? なんて疑問が浮かぶ。
 むぅ、au Music Portに関しては、USBケーブルが今手元にないから試しようがないんだけど、この推理、どうでしょう? ちなみにauのサイトで配布されているW42CAの取説には、そんなことはまったく書いていない。
 しかしねぇ、内蔵メモリが50MBしかないんじゃ、音楽とか入れてる人はあっという間にメモリ不足になっちゃうんじゃないかねぇ。

| | コメント (0) | トラックバック (0)

2006年8月10日 (木)

ケータイの強制再起動

 僕がG'zOne W42CAを使っていることは前にも書いたけど、こいつ、一部報道なんかですでに報じられているとおり、勝手に電源が落ちるバグがあるそうな。
 近所のauショップに行く前にほんとに落ちるかどうかを職場の人に手伝ってもらって検証したところ、本当に落ちる。スラッシュドット・ジャパンの投稿には、引っかかりそうなメッセージの例とか原因とかをいろいろと考察していたけど、auさん、2006年8月4日の段階ではこんなこと言っていたようです。早い話「どうしても気になるなら修理しますよ」ってことですが、製造物責任を放り出したとも取れるこの発言、僕には到底受け入れられるもんじゃない。
 僕はどうしても気になったので、昨日近所のauショップでそのあたりを聞いてみたんだけど、「持ち込み修理になるので1週間ほどお預かりすることになります」だそうな。
 ただ今日になって方針転換をしたようで、こんなことをいってます。「不具合についての確認が取れたため」だなんていってますが、実際は案外影響が大きかったから情報の公開と修正プログラムの無償提供を始めた、ってとこじゃないかな。
 それを読んでケータイアップデートはすぐにやったけど、は~、こんなことなら事業者変えればよかった。

| | コメント (0) | トラックバック (0)

2006年8月 6日 (日)

au Music Port with W42CA

 先月の末にケータイを機種変更した。KDDIは重大なことをしでかしてくれた関係上かなり悩んだんだけど、悩んだ末auを続投、機種はG'zOne W42CAにした。
 今のトレンドなんだろうね、ご他聞にもれずPCと連携して音楽データをやり取りする機能があるんだけど、それがauが今懸命にテコ入れしているau LISTEN MOBILE SERVICE(LISMO!)とLISMO! MUSIC STORE、そのクライアントであるau Music Port(以下amp)が今日のお題目。

 「Music Port」だからといって音楽の転送だけにしか使えないわけじゃなく、アドレス帳やスケジュールをバックアップできる機能があるので、ちょっと使ってみようかな? なんて気になったんだけど、どうもうまく動いてくれない。
 使うことはないとは思っていても使えないと癪なのでいろいろ試すんだけど、どうしてちゃんと動かないのか皆目見当がつかない。

 まずマニュアルをあたってみないことには始まらないので、ampマニュアルの最新版をダウンロードしてみた。そこには次のサービスに依存するような表記があった(マニュアルp.9)ので修正。

サービス名スタート
アップ
状態
Telephony自動開始
B's Recorder GOLD
Library General Service
開始
Windows Audio自動開始
Remote Access
Connection Manager
開始

 マニュアルp.11の記述からすると、付属のUSBケーブルと別売のUSBケーブルの区別はないような印象を受ける。USBドライバ自身はカシオのサイトから最新版をダウンロードしており、デバイスマネージャ上でもUSBデバイスとして正常稼動しているように表示される。
 それでもamp 2.1を起動すると、「ケータイと接続できませんでした。エラーコード:3C0602E7」などと表示されてきちんと認識しない。うちのWindows機にはNorton SystemWorksが入っているが、Norton AntiVirusの警告は出ておらず、ルータをファイアウォールにしているのでパーソナルファイアウォールの警告など出るはずもない。むぅ、なぜだ?

 ちなみにマスストレージモードでは100%正常に動作しているので、amp 2.1側の問題であると考える。  それを裏付けるためにいろいろとググってみたんだが、W44T サポート通信内容に、auのサポートから返ってきた内容を掲載してくれている記述を発見した。曰く、「amp<-->ケータイ間はシリアルモデム通信で通信しているので、この設定に失敗すると正常に通信できない。そのためシリアルモデム周りの設定を自力で書くべし。」らしい。

 ということで自分の環境にあったシリアルモデムの設定を書くわけだけど、その前にamp 2.1が使うRAS設定を見てみる。これは%PREFIX%\Config\ini\RasEntry.pbk(%PREFIX%のデフォルト値はC:\Program Files\KDDI\auMusicPort)というファイルに収められている。こいつを開いてプロパティ画面を見ると、なんとIrDA接続になっているじゃありませんか! これじゃぁ接続できなくて当然。

デバイスがIrDAになってます

 原因が見えてきたところで、次はケータイを接続したままデバイスマネージャを見ると、W42CAが利用するモデム通信用にCOM3が、シリアルモデム用にCOM4がそれぞれ定義されているのを発見。コントロールパネルから「電話とモデムのオプション」->「モデム」を開き、COM4とのシリアルモデムを追加してみた。

2だいのコンピュータ間の通信ケーブルを追加

 この状態でRAS設定のプロパティを見ると、今度はCOM4を使うように設定されている。

今度はCOM4を使うようになってます

 けどこの状態を維持したままampを起動してみても、結果は同じ。

 今度はこいつが使うPPP設定かと思い、ネットワークタブ内のバインドされているプロトコル一覧を見てみる。うちのWindows機にはVMware Playerを入れているので、VMwareが追加するプロトコルがバインドされているのを修正。

VMware Brigde Protocolを外しています

 これでも結果は同じ。むぅ、なぜだ?

 こんなにいうことを聞かないソフトとは思ってなかったが、こんな体たらくを見るとなんだか「糞リス」なんて呼ばれる理由がわかったような気がする。こんなのを何度も見せられると、KDDIは会社として信用できなくなってくるんだが。

 これだけのデータをあげても、「自作PCはサポート外ですのでお答えしかねます。」なんて逃げるんだろうな。この会社は。

| | コメント (0) | トラックバック (0)